
 

 

 

  

 
2018 Knowledge Based AuditsTM of HUD Multifamily Housing Programs 

December 2018 

CCH® ProSystem fx® Knowledge Coach 

Welcome to 2018 Knowledge-Based AuditsTM of HUD Multifamily Housing Programs for Knowledge Coach 

This Release Notes document provides important information about the 2018 release of Knowledge Based AuditsTM of HUD Multifamily 
Housing Programs. Please review this information carefully. If you have any questions, additional information is available on CCH Support 
Online. 

New in this Release  

Knowledge-Based Audits of HUD Multifamily Housing Programs 
 
2018 Knowledge Based Audits of HUD Multifamily Housing Programs can be installed on CCH® ProSystem fx® Engagement v2017 by first 
installing the CCH ProSystem fx Engagement v2017.2.4 Update or later. The latest update can be downloaded here. This update will allow 
users to work on the 2018 HUD Multifamily Housing Programs title without installing ProSystem fx Engagement v2018 until your firm plans 
to update. 

It is designed to help the auditor efficiently and effectively perform audits of housing and urban development programs in accordance with 
auditing standards generally accepted in the United States of America (U.S. GAAS), Government Auditing Standards (GAGAS), and the 
Consolidated Audit Guide to Audits of HUD Programs, published by the U.S. Department of Housing and Urban Development (HUD Audit 
Guide). The Knowledge-Based Audit methodology is also designed to help the auditor efficiently and effectively perform cost certification 
audits in accordance with attestation standards generally accepted in the United States of America, GAGAS, and the HUD Audit Guide. HUD 
audits include both an audit of the financial statements and a compliance audit. The knowledge-based audit, including the compliance 
audit, is a risk-based methodology that emphasizes using knowledge of the entity to make risk assessments in connection with the financial 
statement and compliance audit of a HUD program. This allows the auditor to more appropriately focus audit efforts on those areas which 
in the auditor’s judgment are the most significant and pose the most risk to the audit. The administration of HUD programs includes both 
financial statement and compliance considerations, and requires specialized accounting and auditing knowledge. This module includes up-
to-date guidance for audits of programs identified under Chapter 3, HUD Multifamily Housing Programs. 

Conducting audits of HUD programs requires the exercise of the auditor’s professional judgment and knowledge of the requirements of the 
HUD Audit Guide. This document is published for the purpose of communicating, to users of the toolset, updates, and enhancements 
included in the current version. This document is not, and should not be used as an audit program to update the audit documentation of an 
engagement started in a previous version of this product. 

This document is published for the purpose of communicating the updates and enhancements included in the current version to users of 
the toolset. This document is not, and should not be used as an audit program to update the audit documentation of an engagement 
started in a previous version of this product. 

If you are updating from a previous version of this title, refer to the Knowledge Coach User Guide Chapter 12. The guide is found on the 
Engagement File Room Help menu.  

http://support.cch.com/productsupport/
http://support.cch.com/productsupport/
https://support.cch.com/updates/Engagement/release2017/release2017.aspx
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The 2018 documents include CCH® Accounting Research® material links to specific guidance that provides instant access to detailed analysis 
related to the steps and processes discussed in the workpapers.  

2018 Edition of Knowledge-Based Audits of HUD Multifamily Housing Programs 
This edition features numerous enhancements, including:  

• Adding links to TeamMate Analytics throughout the AUD-800 series programs to assist the auditor with analytical procedures that 
are beneficial in the audit process. 

• Enhanced instructions and procedures throughout the toolset to improve workflow. 

• Reorganization of multiple areas within the Audit Programs to increase efficiency and improve workflow. 

• New and reorganized columns in the workpapers documenting internal controls (KBA-400s) to improve workflow and address 
questions customers have raised in the past. Refer to KCO-001 for more descriptive changes and roll forward considerations. 

• Enhancements to the activity-level control forms with updated subprocesses and activity-level control objectives throughout all the 
KBA-403 series workpapers. 

• Changes to the benchmark/rule of thumb percentage table in KBA-301 Worksheet for Determination of Materiality, Performance 
Materiality, and Thresholds for Trivial Amounts, so users will be able to document a separate benchmark and rule of thumb 
percentage not used in the KBA methodology. 

• A new comments table in AUD-100 Engagement-Level Tailoring Questions to document any information you want to capture 
related to tailoring. 

• New RES-027 Controls Related to FASB ASC 606, Revenue from Contracts with Customer – Five Step Model to assist users whose 
clients have adopted the new Revenue Recognition Standards. 

• Incorporating audit recommendations from AICPA’s Audit and Accounting Guide: Revenue Recognition, including several new 
revenue related steps in AUD-803 Audit Program: Revenue and Accounts Receivable. 

• New tips for the new proposed statements on auditing standards and new finalized FASB standards, including Omnibus Statement 
Auditing Standards, 2018. 

• Updating audit program name for AUD-809 from Payroll and Other Liabilities to Payroll and Related Liabilities. 

• A new example planned response to Management Override of Controls in KBA-502 which flows to the AUD-800 series. This can be 
modified in the risk pane for the Financial Statement Level Risk of Management Override of Controls and should be modified by the 
user based on the specific audit. 

• Adding many new AUDs, CORs, and RESs as follows: 

o AUD-910 Audit Program: Specific Element, Account or Item of a Financial Statement  

o COR-203A Entity Consent and Acknowledgment Letter 

o COR-204 Request from Entity to Predecessor Auditor to Release Information to Successor Auditor 

o COR-912 Management Letter Comments – Illustration 

o RES-028 Controls Related to ASC 606, Revenue From Contracts with Customers – Five Step Model 

Click here for the 2018 Audits of HUD Multifamily Housing Programs Title Overview for Knowledge Coach Users. 

 

 

http://engagetax.wolterskluwer.com/l/339101/2018-03-29/2w349
http://support.cch.com/updates/KnowledgeCoach/pdf/guides_tab/2018%20HUD%20Title%20Overview%20for%20Knowledge%20Coach%20Users.pdf
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In addition, forms and practice aids throughout have been updated to include new examples and tips, and where applicable, to take into 
account: 

New literature, standards, and developments, reflected in the following current audit and accounting guidance:  

• FASB Accounting Standards Codification™ as of September 30, 2018, through Accounting Standards Update No. 2018-15 
• AICPA Statement on Auditing Standards (SAS) No. 133, Auditor Involvement with Exempt Offering Documents 
• AU-C 940, An Audit of Internal Control Over Financial Reporting That Is Integrated With an Audit of Financial Statements 

 

Important Notes: 

• Make sure to save changes to workpapers before closing the workpaper or the binder to ensure data is correctly updated. 

• If your Current Editor Knowledge Coach Microsoft® Word workpapers become read-only or crash, please do the following: 

o Keep the binder with the affected workpapers open. 

o Highlight the workpaper in the binder window and go to Tools > Save Knowledge Coach Answers. 

System Requirements 
• This title requires the 2018 Financial Statement Base Title and the 2018 Compliance Audits Base Title. The 2018 Financial Statement 

Base title and the 2018 Compliance Audits Base title MUST be installed with one of the following versions of CCH® ProSystem fx ® 
Engagement and Knowledge Coach.  

o Engagement and Knowledge Coach v2017 with CCH ProSystem fx Engagement v2017.2.4 Update or later available here. 
To identify what version you are running, please go to the Help > About window within the application.  

o Engagement and Knowledge Coach v2018 or later. 

• If you are upgrading from Engagement v7.1 or lower, please contact Technical Support. 

• A minimum of 4GB of RAM is required for optimal performance when opening and navigating through Knowledge Coach 
workpapers. 

License Requirements 
• This title requires the Knowledge-Based Audits of HUD Multifamily Housing Programs license.  

Any user that does not have a license for this title will not be able to use Knowledge Coach functionality in workpapers.  

• For more information on how to update your licensing, view How do I add or update CCH ProSystem fx Engagement Licenses? on 
our website.  

• For more information on how to assign licenses, view How do I assign Engagement Licenses? on our website. 

Download Instructions 

If you are planning to use this title on Engagement and Knowledge Coach v2017, ensure you apply CCH ProSystem fx Engagement v2017.2.4  
Update to all machines including Admin servers and terminal servers before installing the title. Review the Update's release notes for more 
information on deployment. 

To download this title: 

1. Navigate to the Knowledge Coach Updates section of the Engagement Support Website.  

2. Select the Knowledge Coach Series. The series are arranged by title type, then industry. 

3. Click on the Download File link next to the title you wish to download. 

https://support.cch.com/updates/Engagement/release2017/release2017.aspx
https://support.cch.com/contact
https://support.cch.com/kb/solution.aspx/sw3937
https://support.cch.com/kb/solution.aspx/sw3943
https://support.cch.com/updates/Engagement/patch75/ENG%202017.2.4%20Release%20Notes.pdf
http://support.cch.com/updates/KnowledgeCoach
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Note: On some occasions the content package file (.KCP) will download with the extension changed to .ZIP. If this occurs, please change the 
extension of the downloaded file to KCP using all capital letters. 

You must install the 2018 Financial Statement Base title and the 2018 Compliance Audit Base title before installing the 2018 Knowledge 
Based Audits of HUD Multifamily Housing Programs.  

The Financial Statement and Compliance Audit Base title is also available on the Knowledge Coach Update Website.    

The Knowledge Coach Content Package (KCP) download is a proprietary file that must be installed from within Engagement. Save this KCP 
file to a location on your local drive, and follow the Installation Instructions below. 

Installation Instructions 

Once you have downloaded your Knowledge Coach title, you will need to add it to the list of titles within CCH ProSystem fx Engagement. 
The only additional system requirement is approximately 75MB of disk space to store your Knowledge Coach Program content files. Please 
refer to the Engagement with Knowledge Coach Release Notes for any other system requirements.  

After downloading the 2018 Knowledge Based Audits of HUD Multifamily Housing Programs, do the following: 

1. Launch the Engagement Workpaper Management application so that the Local File Room is displayed. Select Tools > Knowledge 
Coach Titles.  

2. The Knowledge Coach Titles window will be displayed.  

3. Choose Add Title.  

4. Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge Coach Support Web site.  

5. Choose Open.  

6. The system will display a progress indicator while the title package is added. You will receive a message that the title has been 
successfully installed once the process is complete. 

To release a title:  

1. Select one of the Knowledge Coach titles in the list that has been added but is not yet released.  

2. Choose Release Title. The current date and time will be displayed in the Date released column, and the status will change to 
“Released.”  

Note: In the Engagement Admin module, add and assign a Knowledge Coach module and the applicable Knowledge Coach title license to 
staff before using the workpapers. 

Important: Once the 2018 Knowledge-Based Audits of the HUD Multifamily Housing Programs title has been added and released, they will 
be automatically deployed to other staff members when they login to the “Office” location, or when they synchronize a binder that 
contains Knowledge Coach workpapers from this title.  

Online Permission Key 

Permission key files may be downloaded from our website or when adding or updating the new licenses within CCH ProSystem fx 
Engagement v2017 and higher. After updating the license file in the Engagement Admin module, licenses need to be assigned to the staff 
who will use 2018 Knowledge-Based Audits of HUD Multifamily Housing Programs. 

If you have not already established a Single Sign-on (SSO) account with Customer Service, we urge you to do so at this time.  

http://support.cch.com/updates/KnowledgeCoach
https://prosystemfxsupport.tax.cchgroup.com/permkey/download.aspx
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CCH® Accounting Research Manager® 

CCH’s Accounting Research Manager ("ARM") is the most comprehensive, up-to-date and objective online database of financial reporting 
literature. It includes all authoritative and proposed accounting, auditing, and SEC literature, plus independent, expert-written interpretive 
guidance.  

Available on ARM, the Knowledge-Based Audits of HUD Multifamily Housing Programs Guide helps you comply with the most recent 
professional standards and guidance for the conduct of audits of HUD Multifamily Housing Programs and to integrate the use of practice 
aids, tools, and other resources with its guidance. This publication supplements and complements the Knowledge-Based documents that 
are available in Knowledge Coach. 

If you subscribe to an ARM library that includes HUD Multifamily Housing Programs content, you can link directly to source material from 
Resources within Knowledge Coach documents. These links have been updated to refer to the accounting standards under the FASB 
Accounting Standards Codifications. Also, if you subscribe to the Knowledge-Based Audits of HUD Multifamily Housing Programs Guide on 
ARM, you can take advantage of references to the guide material from within the Knowledge Coach documents.  

With Accounting Research Manager, you maximize the efficiency of your research time, while enhancing your results. Learn more about our 
content, our experts, and how you can request your free trial by visiting the Accounting Research Manager website. You can also access the 
Accounting Research Manager Web site by selecting Engagement > Binder Window > Shortcuts Bar > Guidance tab.  

Using Your Knowledge Coach Content 
To use your Knowledge Coach Workpaper Templates, do the following: 

1. Open a binder in Engagement. 

2. Select the workpaper tab into which you would like to insert the workpaper. 

3. Select New Knowledge Coach Workpaper from the toolbar or File menu. 

4. The New Knowledge Coach Workpaper dialog appears (Figure 1).  

5. Select the New Knowledge Coach Title with the content you would like to use. You can only select titles you have installed. The 
information displayed changes to reflect the workpaper organization available for the selected title.  

6. Select the Knowledge Coach Workpapers to insert into your binder and click OK.  

7. In the Selected Workpaper Properties dialog, each workpaper name is automatically loaded into the Name field. Add a workpaper 
index in the Index field and make any Name modifications you desire. You can also modify the tab location or the roll forward 
settings for each workpaper. 

8. Click OK. The integrated Knowledge Coach workpaper is now inserted into your engagement binder.  

Note: For more information on how to use Knowledge Coach workpapers in your binder, see the Knowledge Coach User Guide.  

http://www.accountingresearchmanager.com/
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Additional Information on Knowledge Coach and the KBA Methodology 

Knowledge-Based Audit (KBA) Methodology 
Allows the results of one set of procedures to become the input for the next. The key components of the KBA methodology include: 
 

• An Overview that guides auditors through the methodology; 

• Knowledge-Based Audit documents, integral to the risk assessment and overall audit processes, which contain steps and 
procedures required by U.S. GAAS, GAGAS, and the HUD Audit Guide; 

Figure 1 - New Knowledge Coach Workpaper 
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• Customizable Audit Programs that take auditors through related steps and procedures; 

• Practice Aids to help auditors complete steps or processes outlined in the Knowledge-Based Audit documents and Audit Programs; 

• Auditor’s Reports that provide a variety of sample auditor’s opinions on audited financial statements; and 

• Correspondence documents that provide sample letters to be used to comply with U.S. GAAS, GAGAS, and the HUD Audit Guide 
requirements and in many other common situations. 

• The AICPA’s Auditing Standards Board’s (ASB) Risk Assessment Standards - The practice aids and tools in the 2018 Knowledge-
Based Audits of HUD Multifamily Housing Programs are designed around the AICPA’s risk assessment and clarified standards to 
assist auditors of financial institutions by: 

– Facilitating compliance with GAAS, GAGAS, and the HUD Audit Guide; 

– Encouraging more effective audits through tailored audit programs and comprehensive practice aids;  

– Helping auditors to focus on and respond to identified audit risks; and 

– Enhancing audit documentation. 

CCH® ProSystem fx® Knowledge Coach 

Knowledge Coach functionality allows auditors to use the Knowledge-Based-Audit methodology more efficiently by eliminating the need for 
duplicate entry of the same information, tailoring audit documentation to each particular engagement, and documenting the link between 
risks identified and procedures performed. AUD-100 Tailoring Question is a document in Knowledge Coach that presents engagement-level 
questions designed to aid in tailoring the engagement documentation to fit each client. Completing the questions helps the auditor avoid 
duplication and unnecessary workpapers.  

Note: Before you begin your audit, please review the guidance in AUD-103 Overall Audit Program. This workpaper is intended to be your 
road map through a Knowledge-Based Audit methodology. You should start your audit with AUD-100 Tailoring Question Workpaper and 
AUD-103 Overall Audit Program. 

• Risks  
Can be captured via the Risk Summary task pane from any Knowledge Coach workpaper by the current editor of KBA-502 
Summary of Risk Assessments. This allows the user to continuously assess risks during the engagement. Several workpapers 
prompt the consideration of the presence of risks, but the Risk Summary task pane must be used to document those risks. All 
documented risks flow to the Risk Summary. To ensure risks show in findings tables, make sure to check the “workpaper identified 
in” field of the Risk pane. 
 

• Information Flow  
Helps cut down on the time spent duplicating information across forms. In addition, the flow of consistent information ensures 
that information and updates to information are not missed between workpapers. Drill-down functionality helps the user navigate 
quickly to the source of the information, aiding in the review of the audit file. 
 

• Diagnostics  
Help keep track of unresolved issues like unanswered questions, incomplete risks, program steps not linked to risks or relevant 
assertions, missing workpaper, and more.  
 

• Links to Accounting Research Manager (ARM) 
If you subscribe to an ARM library that includes audit content, you can link directly to source material from Resources within 
Knowledge Coach workpapers. These links have been updated to reference to the accounting standards under the FASB 
Accounting Standards Codifications and the auditing standards issued by the AICPA. Also, if you subscribe to the Knowledge-Based 
Audits of HUD Multifamily Housing Programs Guide on ARM, you can take advantage of links to the audit guide material from 
within the Knowledge Coach documents. 
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• Interpretive Guidance 
It is integrated into each Knowledge Coach template through the Tips view of each new task pane. Informational features include 
Practice Points, Examples, Optional Workpapers, and Resources to help auditors work more effectively and efficiently. You can 
also navigate from Resources within a document or the tip pane directly to CCH’s Accounting Research Manager and industry 
audit guides by simply clicking on the Reference.  
 
 

Download Description: 2018 Knowledge-Based Audits of HUD Multifamily Housing Programs 

Version: 

Engagement and Knowledge Coach v2017 with CCH ProSystem fx Engagement v2017.2.4 Update or 
later 
OR  
Engagement and Knowledge Coach v2018 or later 

2018 Financial Statement Base 

Release Date: December 2018 

File size: 18MB 

Approx. Download Time: 42 minutes at 56 kbps 

License: Full Version 

Platforms: Microsoft® Windows® 7, 8.1, 10 

Office: Microsoft® Office 2013 or higher required 

 


	CCH® ProSystem fx® Knowledge Coach
	New in this Release
	Knowledge-Based Audits of HUD Multifamily Housing Programs
	2018 Edition of Knowledge-Based Audits of HUD Multifamily Housing Programs This edition features numerous enhancements, including:
	System Requirements
	License Requirements

	Download Instructions
	Installation Instructions
	Online Permission Key
	CCH® Accounting Research Manager®
	Using Your Knowledge Coach Content
	Additional Information on Knowledge Coach and the KBA Methodology


