
 

  

 
2019 Knowledge Based Examinations of Service Organizations 

March 2019 

CCH® ProSystem fx® Knowledge Coach 

Welcome to 2019 Knowledge-Based Examinations of Service Organizations for Knowledge Coach 

This Release Notes document provides important information about the 2019 release of Knowledge Based Examinations of Service 
Organizations. Please review this information carefully. If you have any questions, additional information is available on CCH Support 
Online. 

New in this Release  

Knowledge-Based™ Examinations of Service Organizations 
 
2019 Knowledge Based Examinations of Service Organizations can be installed on CCH® ProSystem fx® Engagement v2017 by first installing 
the CCH ProSystem fx Engagement v2017.2.4 Update or later. The latest update can be downloaded here. This update will allow users to 
work on the 2018 Service Organizations title without installing ProSystem fx Engagement v2018 until your firm plans to update. 

This title is designed to help the practitioner efficiently and effectively conduct examination engagements of service organizations in 
accordance with applicable standards issued by the American Institute of Certified Public Accountants (AICPA). The knowledge-based 
methodology for service organization engagements is a risk-based methodology for conducting examination engagements of service 
organizations. It emphasizes using knowledge of the entity, subject matter, and criteria to make the risk assessments and recommendations 
in connection with an engagement. The more accurately a practitioner assesses risks of material misstatement or deviation, the more 
assurance the practitioner has that the procedures performed in response to the risk assessments will detect material misstatements or 
deviations. 

Examination of Service Organizations are often unique and complex, and require specialized accounting, and attestation knowledge. 
Conducting Examination of Service Organizations requires the exercise of the practitioner’s professional judgment. This edition includes 
specific up-to-date guidance for Examination of Service Organizations and is published for the purpose of communicating, to users of the 
toolset, updates and enhancements included in the current version. This document is not, and should not be used as an engagement 
program to update the documentation of an engagement started in a previous version of this product. 

The forms and practice aids in the knowledge-based methodology will help the practitioner perform the procedures necessary to complete 
the engagement in accordance with professional standards. The Knowledge-Based tools include documents, attestation programs, practice 
aids, correspondence, and example reports. 

Although the KBA approach provides a framework for applying attestation standards, it is not a substitute for knowledge of professional 
standards and the exercise of the practitioner’s professional judgment and professional skepticism. The practitioner may need to refer to 
additional resources to determine how to apply the applicable standards to unfamiliar or unique circumstances. 

This document is published for the purpose of communicating the updates and enhancements included in the current version to users of 
the toolset. This document is not, and should not be used as an audit program to update the audit documentation of an engagement 
started in a previous version of this product. 

If you are updating from a previous version of this title, refer to the Knowledge Coach User Guide Chapter 12. The guide is found on the 
Engagement File Room Help menu.  

http://support.cch.com/productsupport/
http://support.cch.com/productsupport/
https://support.cch.com/updates/Engagement/release2017/release2017.aspx
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The 2019 documents include CCH® Accounting Research® material links to specific guidance that provides instant access to detailed analysis 
related to the steps and processes discussed in the workpapers.  

2019 Edition of Knowledge-Based Examinations of Service Organizations  
This edition features numerous enhancements, including:  

• New and reorganized columns in the workpapers documenting internal controls (ATT-401 and ATT-402) to improve workflow and 
address questions customers have raised in the past. Refer to KCO-001 for more descriptive changes and roll forward 
considerations. 

• A new comments table in AUD-100 Engagement-Level Tailoring Questions to document any information you want to capture 
related to tailoring. 

• A new table in KBA-501, under Section 2, to allow user in SOC 2 and SOC 3 engagements to document risks by TSP/COSO categories. 
Please note that risks identified in other workpapers will flow to Table 1.  For SOC 1 engagements, the auditor should add additional 
risks in Table 1.  For SOC 2 and SOC 3 engagements, the auditor should add additional risks by TSP/COSO category in Table 2. 

o Table 1 will always be shown no matter the type of engagement 

o Table 2 will only show for SOC 2 and SOC 3 Engagements 

• Many new documents in this title as follows: 

o AID-703 Trust Services Criteria for Security, Availability, Processing Integrity, Confidentiality, and Privacy Description of 
Test of Controls and Results Thereof 

o AID-916 Report Preparation Checklist: Engagement to Report on a Service Organization’s Controls (SOC 3) 

o COR-212 Engagement Letter: Engagement to Report on Controls at a Service Organization Relevant to Security, 
Availability, Processing Integrity, Confidentiality, or Privacy (SOC 3) 

o COR-921 Representation Letter – SOC 3 Engagements 

o RES-008 Criteria for Evaluating the Fairness of the Presentation of the Description (Description Criteria) DC Section 200A 
Provides 2015 Description Criteria – DC Section 200A. 

o RES-009 Description Criteria for a Description of a Service Organization’s System in a SOC 2 Examination and Related 
Implementation Guidance DC Section 200 Provides 2018 Description Criteria – DC Section 200. 

o RES-013 Service Auditor's Engagement (SOC 1): Illustrative Subservice Organization Management Assertions for a Type 2 
Report 

o RES-017 Service Auditor’s Engagement (SOC 2): Illustrative Subservice Organization Management Assertions for a Type 2 
Report Provides an illustrative example of a SOC 2 Subservice Organization Management Assertion when the Inclusive 
Method is used. 

o RES-020 Illustrative Comparison of a SOC 2 Examination and Related Report With the Cybersecurity Risk Management 
Examination and Related Report 

o RES-021 SOC 2 Sample Reporting Package - Illustration Only 

o RPT-1055 Service Auditor’s Engagement (SOC 2): Unmodified Opinion on a Description of Cloud Service Organization 

o RPT-1056 Service Auditor’s Engagement (SOC 2): Unmodified Opinion on a Health Care Organization 

o RPT-1060 Service Auditor's Engagement (SOC 2): Unmodified Opinion on a Description of a Service Organization's System 
and the Suitability of the Design and Operating Effectiveness of Controls Relevant to Security, Availability, Processing 
Integrity, Confidentiality, and Privacy When Reporting Under AT-C Section 205 and ISAE 3000 (Revised) 
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Click here for the 2019 Examination of Service Organizations Title Overview for Knowledge Coach Users. 

In addition, forms and practice aids throughout have been updated to include new examples and tips, and where applicable, to take into 
account: 

New literature, standards, and developments, reflected in the following current audit and accounting guidance:  

• AICPA Auditing Standards Board (ASB) Statements on Standards for Attestation Engagements (SSAEs), Attestation Standards: 
Clarification and Recodification (SSAE No. 18) 

• 2011 Revision of Government Auditing Standards (GAGAS, or the Yellow Book; QC Section 10, A Firm’s System of Quality Control 

• The revised AICPA Code of Professional Conduct (Code), including the provisions of ET Section 1.295, Nonattest Services 

• AICPA AAG, Reporting on Controls at a Service Organization Relevant to Security, Availability, Processing Integrity, Confidentiality, 
or Privacy (SOC 2) – Revised 2018, 2017 Trust Services Criteria, and DC Section 200 – 2018 Description Criteria 

 
Important Notes: 

• Make sure to save changes to workpapers before closing the workpaper or the binder to ensure data is correctly updated. 

• If your Current Editor Knowledge Coach Microsoft® Word workpapers become read-only or crash, please do the following: 

– Keep the binder with the affected workpapers open. 

– Highlight the workpaper in the binder window and go to Tools > Save Knowledge Coach Answers. 

System Requirements 

• This title requires the 2018 Financial Statement Base Title. The 2018 Financial Statement Base title must be installed with one of the 
following versions of CCH® ProSystem fx ® Engagement and Knowledge Coach.  

o Engagement and Knowledge Coach v2017 with CCH ProSystem fx Engagement v2017.2.4 Update or later available here. 
To identify what version you are running, please go to the Help > About window within the application.  

o Engagement and Knowledge Coach v2018 or later. 

• If you are upgrading from Engagement v7.1 or lower please contact Technical Support. 

• A minimum of 4GB of RAM is required for optimal performance when opening and navigating through Knowledge Coach 
workpapers. 

License Requirements 

This title requires the Knowledge-Based SOC Engagement license.  
Any user that does not have a license for this title will not be able to use Knowledge Coach functionality in workpapers.  

For more information on how to update your licensing, view How do I add or update CCH ProSystem fx Engagement Licenses? on our 
website.  

For more information on how to assign licenses, view How do I assign Engagement Licenses? on our website. 

http://support.cch.com/updates/KnowledgeCoach/pdf/guides_tab/2019%20Service%20Organizations%20Title%20Overview%20for%20Knowledge%20Coach%20Users.pdf
https://support.cch.com/updates/Engagement/release2017/release2017.aspx
https://support.cch.com/contact
https://support.cch.com/kb/solution.aspx/sw3937
https://support.cch.com/kb/solution.aspx/sw3943


 

4 

 

Download Instructions 

If you are planning to use this title on Engagement and Knowledge Coach v2017, ensure you apply the CCH ProSystem fx Engagement 
v2017.2.4  Update to all machines including Admin servers and terminal servers before installing the title. Review the Update's release 
notes for more information on deployment. 

To download this title: 

1. Navigate to the Knowledge Coach Updates section of the Engagement Support Website.  

2. Select the Knowledge Coach Series. The series are arranged by title type, then industry. 

3. Click on the Download File link next to the title you want to download. 

Note: On some occasions, the content package file (.KCP) will download with the extension changed to ZIP. If this occurs, please change the 
extension of the downloaded file to KCP using all capital letters. 

You must install the 2018 Financial Statement Base title before installing the 2019 Knowledge Based Examination of Service Organizations.  

The Financial Statement Base title is also available on the Knowledge Coach Update Website.    

The Knowledge Coach Content Package (KCP) download is a proprietary file that must be installed from within Engagement. Save this KCP 
file to a location on your local drive, and follow the Installation Instructions below. 

Installation Instructions 

Once you have downloaded your Knowledge Coach title, you will need to add it to the list of titles within CCH ProSystem fx Engagement. 
The only additional system requirement is approximately 75MB of disk space to store your Knowledge Coach Program content files. Please 
refer to the Engagement with Knowledge Coach Release Notes for any other system requirements.  

After downloading the 2019 Knowledge Based Examination of Service Organizations, do the following: 

1. Launch the Engagement Workpaper Management application so that the Local File Room is displayed.  

2. Select Tools > Knowledge Coach Titles.  

3. The Knowledge Coach Titles window will be displayed.  

4. Click Add Title.  

5. Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge Coach Supportwebsite.  

6. Click Open.  

The system will display a progress indicator while the title package is added. You will receive a message that the title has been 
successfully installed once the process is complete. 

To release a title:  

1. Select one of the Knowledge Coach titles in the list that has been added, but is not yet released.  

2. Click Release Title. The current date and time will be displayed in the Date released column, and the status will change to 
“Released.”  

Note: In the Engagement Admin module, add and assign a Knowledge Coach module and the applicable Knowledge Coach title license to 
staff before using the workpapers. 

https://d2iceilwdglxpz.cloudfront.net/release_notes/CCH%20ProSystem%20fx%20Engagement%20Release%20Notes%202017.2.4.pdf
https://d2iceilwdglxpz.cloudfront.net/release_notes/CCH%20ProSystem%20fx%20Engagement%20Release%20Notes%202017.2.4.pdf
http://support.cch.com/updates/KnowledgeCoach
http://support.cch.com/updates/KnowledgeCoach
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Important: Once the 2019 Knowledge-Based Examination of Service Organizations title has been added and released, they will be 
automatically deployed to other staff members when they log in to the “Office” location, or when they synchronize a binder that contains 
Knowledge Coach workpapers from this title.  

Online Permission Key 

Permission key files may be downloaded from our website or when adding or updating the new licenses within CCH ProSystem fx 
Engagement v2017 and higher. After updating the license file in the Engagement Admin module, licenses need to be assigned to the staff 
who will use 2019 Knowledge-Based Examinations of Service Organizations. 

If you have not already established a Single Sign-on (SSO) account with Customer Service, we urge you to do so at this time.  

CCH® Accounting Research Manager® 

CCH’s Accounting Research Manager (ARM) is the most comprehensive, up-to-date and objective online database of financial reporting 
literature. It includes all authoritative and proposed accounting, auditing, and SEC literature, plus independent, expert-written interpretive 
guidance.  

Available on ARM, the Knowledge-Based Examination of Service Organizations Guide helps you comply with the most recent professional 
standards and guidance for the conduct of Examination of Service Organizations and to integrate the use of practice aids, tools, and other 
resources with its guidance. This publication supplements and complements the Knowledge-Based documents that are available in 
Knowledge Coach. 

If you subscribe to an ARM library that includes Examination of Service Organizations content, you can link directly to source material from 
Resources within Knowledge Coach documents. These links have been updated to refer to the accounting standards under the FASB 
Accounting Standards Codifications. Also, if you subscribe to the Knowledge-Based Examination of Service Organizations Guide on ARM, 
you can take advantage of references to the guide material from within the Knowledge Coach documents.  

With Accounting Research Manager, you maximize the efficiency of your research time, while enhancing your results. Learn more about our 
content, our experts, and how you can request your free trial by visiting the Accounting Research Manager. You can also access the 
Accounting Research Manager website by selecting Engagement > Binder Window > Shortcuts Bar > Guidance tab.  

Using Your Knowledge Coach Content 
To use your Knowledge Coach Workpaper Templates, do the following: 

1. Open a binder in Engagement. 

2. Select the workpaper tab into which you would like to insert the workpaper. 

3. Select New Knowledge Coach Workpaper from the toolbar or File menu. 

4. The New Knowledge Coach Workpaper dialog appears (Figure 1).  

5. Select the New Knowledge Coach Title with the content you would like to use. You can only select titles you have installed. The 
information displayed changes to reflect the workpaper organization available for the selected title.  

6. Select the Knowledge Coach Workpapers to insert into your binder and click OK.  

7. In the Selected Workpaper Properties dialog, each workpaper name is automatically loaded into the Name field. Add a workpaper 
index in the Index field and make any Name modifications you desire. You can also modify the tab location or the roll forward 
settings for each workpaper. 

8. Click OK. The integrated Knowledge Coach workpaper is now inserted into your engagement binder.  

https://prosystemfxsupport.tax.cchgroup.com/permkey/download.aspx
http://www.accountingresearchmanager.com/
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Note: For more information on how to use Knowledge Coach workpapers in your binder, see the Knowledge Coach User Guide.  

 

 

Additional Information on Knowledge Coach and the KBA Methodology 

Knowledge-Based Audit (KBA) Methodology 
Allows the results of one set of procedures to become the input for the next. The key components of the KBA methodology include: 
 

• An Overview that guides auditors through the methodology; 

• Knowledge-Based Attestation documents, integral to the risk assessment and overall audit processes, which contain steps and 
procedures required by professional standards; 

• Customizable Engagement Programs that take auditors through related steps and procedures; 

• Practice Aids to help auditors complete steps or processes outlined in the Knowledge-Based Attestation documents and 
Attestation Programs; 

• Practitioner’s Reports that provide a variety of sample practitioner’s opinions on nontraditional engagements; and 

• Correspondence documents that provide sample letters to be used to comply with professional standards, SSAE and SSCS 
requirements and in many other common situations. 

Figure 1 - New Knowledge Coach Workpaper 
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CCH® ProSystem fx® Knowledge Coach 

Knowledge Coach functionality allows auditors to use the Knowledge-Based-Audit methodology more efficiently by eliminating the need for 
duplicate entry of the same information, tailoring audit documentation to each particular engagement, and documenting the link between 
risks identified and procedures performed. ATT-100 Tailoring Question is a document in Knowledge Coach that presents engagement-level 
questions designed to aid in tailoring the engagement documentation to fit each client. Completing the questions helps the auditor avoid 
duplication and unnecessary workpapers.  

Note: Before you begin your engagement, please review the guidance in ATT-101 Overall Attestation Program. This workpaper is intended 
to be your road map through a Knowledge-Based Audit methodology. You should start your audit with ATT-100 Tailoring Question 
Workpaper and ATT-101 Overall Attestation Program. 

• Risks  
Can be captured via the Risk Summary task pane from any Knowledge Coach workpaper by the current editor of KBA-501 Summary 
of Risk Assessments. This allows the user to continuously assess risks during the engagement. Several workpapers prompt the 
consideration of the presence of risks, but the Risk Summary task pane must be used to document those risks. All documented risks 
flow to the Risk Summary. To ensure risks display in findings tables, make sure to check the “workpaper identified in” field of the 
Risk pane. 

• Information Flow  
Helps cut down on the time spent duplicating information across forms. In addition, the flow of consistent information ensures that 
information and updates to information are not missed between workpapers. Drill-down functionality helps the user navigate 
quickly to the source of the information, aiding in the review of the engagement file. 

• Diagnostics  
Help keep track of unresolved issues like unanswered questions, incomplete risks, program steps not linked to risks or relevant 
assertions, missing workpaper, and more.  

• Links to Accounting Research Manager (ARM) 
If you subscribe to an ARM library that includes audit content, you can link directly to source material from Resources within 
Knowledge Coach workpapers. These links have been updated to reference to the accounting standards under the FASB Accounting 
Standards Codifications and the auditing standards issued by the AICPA. Also, if you subscribe to the Knowledge-Based 
Examinations of Service Organizations Guide on ARM, you can take advantage of links to the audit guide material from within the 
Knowledge Coach documents. 

• Interpretive Guidance 
It is integrated into each Knowledge Coach template through the Tips view of each new task pane. Informational features include 
Practice Points, Examples, Optional Workpapers, and Resources to help auditors work more effectively and efficiently. You can also 
navigate from Resources within a document or the tip pane directly to CCH’s Accounting Research Manager and industry audit 
guides by simply clicking on the Reference.  

 
 
 
 
 

Download Description: 2019 Knowledge-Based Examination of Service Organizations  

Version: 

Engagement and Knowledge Coach v2017 with CCH ProSystem fx Engagement v2017.2.4 Update or 
later 
OR  
Engagement and Knowledge Coach v2018 or later 

2018 Financial Statement Base 
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Release Date: March 2019 

File size: 18MB 

Approx. Download Time: 42 minutes at 56 kbps 

License: Full Version 

Platforms: Microsoft® Windows® 7, 8.1, 10 

Office: Microsoft® Office 2013 or higher required 
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